A-A+

MIT Kerberos 5 validate_as_request函数拒绝服务漏洞(CVE-2016-3120)

2016年08月03日 Linux 教程 暂无评论 阅读 443 次
MIT Kerberos 5 validate_as_request函数拒绝服务漏洞(CVE-2016-3120)

发布日期:2016-07-31
更新日期:2016-08-02

受影响系统:

MIT Kerberos 5 < 1.13.6
MIT Kerberos 5 1.4.x < 1.14.3

描述:


CVE(CAN) ID: CVE-2016-3120

Kerberos是一款广泛使用的超强加密来验证客户端和服务器端的网络协议。

MIT Kerberos 5 < 1.13.6、1.4.x < 1.14.3版本,启用restrict_anonymous_to_tgt后,Key Distribution Center (KDC)/kdc_util.c/validate_as_request函数使用了不正确的客户端数据结构。通过S4U2Self请求,远程用户可造成拒绝服务(空指针间接引用及后台程序崩溃)。

<*来源:vendor
  *>

建议:


厂商补丁:

MIT
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://krbdev.mit.edu/rt/Ticket/Display.html?id=8458

https://github.com/krb5/krb5/commit/93b4a6306a0026cf1cc31ac4bd8a49ba5d034ba7

http://web.mit.edu/kerberos/krb5-1.14/

http://web.mit.edu/kerberos/krb5-1.13/

标签:

给我留言

Copyright © SEARU.ORG 保留所有权利.   Theme  Ality 网站地图 360网站安全检测平台

用户登录

分享到: