A-A+

Linux安装其他版本GCC的方法

2016年08月10日 Linux 教程 暂无评论 阅读 519 次

前言

有时候,在Linux中需要安装固定版本的GCC,才能满足工作要求。例如:在Fedora22中,编译OpenCV的cuda部分需要GCC 4.9.X及以下的版本,而Fedora22的GCC是在5.1-5.3版本之间。又例如:编译Caffe中的matcaffe需要GCC 4.7.X及以下的版本。所以安装过低版本的GCC时通常要自己动手,下面是常规操作:

1.下载GCC

在GCC官网http://www.gnu.org/prep/ftp.html上,寻找China,选择一个镜像地址。如http://mirror.hust.edu.cn/gnu/gcc/。选择对应版本gcc-4.9.4/,下载gcc-4.9.4.tar.gz压缩包到本地。

解压到当前文件夹下:

$ tar -zxvf gcc-4.9.4.tar.gz

2.下载编译所需依赖项

$ cd gcc-4.9.4
$ ./contrib/download_prerequisites 
$ cd ..

3.建立编译输出目录

$ mkdir gcc-build-4.9.4

4.生成makefile文件

进入输出目录,执行命令,并生成makefile文件

$ cd gcc-build-4.9.4
$ ../gcc-4.9.4/configure --enable-checking=release --enable-languages=c,c++ --disable-multilib

5.编译

$ make -j24

接下来就是等待了,整个过程大约40分钟左右。PS:最好不要在编译过程中再去做别的什么事,整个过程CPU都是满载的,要是莫名终止了,后面麻烦事也不少。

6.安装

编译结束以后,我们就可以执行安装了:

# make install

7.检查版本

$ gcc -v
$ g++ -v

Linux升级GCC 4.8.1清晰简明教程(Ubuntu 12.04 64位版为例)  2014-04/99583.htm 

Ubuntu 14.04 LST安装GCC 4.1.2  2016-06/132040.htm

Ubuntu下Vim+GCC+GDB安装及使用  2013-01/78159.htm 

Ubuntu下两个GCC版本切换  2012-10/72284.htm 

CentOS6.5升级手动安装GCC4.8.2  2015-01/112595.htm 

GCC 的详细介绍请点这里

标签:

给我留言

Copyright © SEARU.ORG 保留所有权利.   Theme  Ality 网站地图 360网站安全检测平台

用户登录

分享到: